Elvas Tower: Route Curve Squeal Sounds No Longer Working - Elvas Tower

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Route Curve Squeal Sounds No Longer Working Rate Topic: -----

#1 User is online   Traindude 

  • Engineer
  • Group: Status: Contributing Member
  • Posts: 697
  • Joined: 17-November 13
  • Gender:Male
  • Location:Seattle, WA
  • Simulator:Open Rails
  • Country:

Posted 15 May 2024 - 08:04 PM

About a week ago, the route-based curve squeal sounds were working fine in the then-current Unstable version. Now, in the most recent Unstable version, the curve squeal stopped working. Is anyone else experiencing this?

#2 User is offline   steamer_ctn 

  • Open Rails Developer
  • Group: Status: Elite Member
  • Posts: 1,921
  • Joined: 24-June 11
  • Gender:Male
  • Country:

Posted 18 May 2024 - 10:06 PM

At the moment (in the Unstable version) there are three ways to add curve squeal.

Can you describe the method that you are using to add curve squeal.

#3 User is online   Traindude 

  • Engineer
  • Group: Status: Contributing Member
  • Posts: 697
  • Joined: 17-November 13
  • Gender:Male
  • Location:Seattle, WA
  • Simulator:Open Rails
  • Country:

Posted 18 May 2024 - 10:19 PM

View Poststeamer_ctn, on 18 May 2024 - 10:06 PM, said:

At the moment (in the Unstable version) there are three ways to add curve squeal.

Can you describe the method that you are using to add curve squeal.


Okay. I retrofitted your test route and the ZigZag route with the sounds, and here's what the ttype.dat and *.trk file entries look like:
SIMISA@@@@@@@@@@JINX0t1t______

20
TrackType ( "Default" 				"ctn_steamtrack0in-2.sms" "ctn_steamtrack0ex-2.sms"	)
TrackType ( "Concrete Supported"		"ctn_steamtrack1in-2.sms" "ctn_steamtrack1ex-2.sms"	)
TrackType ( "Wood Supported" 			"ctn_steamtrack2in-2.sms" "ctn_steamtrack2ex-2.sms"	)
TrackType ( "In Tunnel" 			"ctn_steamtrack3in-2.sms" "ctn_steamtrack3ex-2.sms"	)
TrackType ( "Steel Bridge" 			"ctn_steamtrack4in-2.sms" "ctn_steamtrack4ex-2.sms"	)
TrackType ( "Girder Bridge" 			"ctn_steamtrack5in-2.sms" "ctn_steamtrack5ex-2.sms"	)
TrackType ( "Under Bridge" 			"ctn_steamtrack6in-2.sms" "ctn_steamtrack6ex-2.sms"	)
TrackType ( "Concrete Bridge" 		"ctn_steamtrack7in-2.sms" "ctn_steamtrack7ex-2.sms"	)
TrackType ( "Crossing Platform" 		"ctn_steamtrack8in-2.sms" "ctn_steamtrack8ex-2.sms"	)
TrackType ( "Wooden Bridge" 			"ctn_steamtrack9in-2.sms" "ctn_steamtrack9ex-2.sms"	)
TrackType ( "Default" 				"ctn_steamtrack0in-2.sms" "ctn_steamtrack0ex-2.sms"	)
TrackType ( "Concrete Supported"		"ctn_steamtrack1in-2.sms" "ctn_steamtrack1ex-2.sms"	)
TrackType ( "Wood Supported" 			"ctn_steamtrack2in-2.sms" "ctn_steamtrack2ex-2.sms"	)
TrackType ( "In Tunnel" 			"ctn_steamtrack3in-2.sms" "ctn_steamtrack3ex-2.sms"	)
TrackType ( "Steel Bridge" 			"ctn_steamtrack4in-2.sms" "ctn_steamtrack4ex-2.sms"	)
TrackType ( "Girder Bridge" 			"ctn_steamtrack5in-2.sms" "ctn_steamtrack5ex-2.sms"	)
TrackType ( "Under Bridge" 			"ctn_steamtrack6in-2.sms" "ctn_steamtrack6ex-2.sms"	)
TrackType ( "Wooden Bridge" 			"ctn_steamtrack9in-2.sms" "ctn_steamtrack9ex-2.sms"	)
TrackType ( "Pointwork" 			"ctn_steamtrack18in.sms" "ctn_steamtrack18ex.sms"	)
TrackType ( "Curve Squeal" 			"flange_in.sms" "flange_ex.sms"	)


	ORTSCurveSquealSMSNumber ( 19 )


NOTE: The reason for the duplicated entries in the ttype.dat file is that the second instance of each entry was originally a "<track type> + flange" entry. These are now made redundant thanks to the addition of the ORTSCurveSquealSMSNumber parameter.

Everything worked fine until about three weeks ago, when the automatic curve squeal stopped working.

Likewise, when I retrofit the default routes with the curve squeal, I write this:
SIMISA@@@@@@@@@@JINX0t1t______

11
TrackType ( "Default" 				"USATrack0In.sms" "USATrack0Ex.sms"	)
TrackType ( "Concrete Supported"	"USATrack1In.sms" "USATrack1Ex.sms"	)
TrackType ( "Wood Supported" 		"USATrack2In.sms" "USATrack2Ex.sms"	)
TrackType ( "In Tunnel" 			"USATrack3In.sms" "USATrack3Ex.sms"	)
TrackType ( "Steel Bridge" 			"USATrack4In.sms" "USATrack4Ex.sms"	)
TrackType ( "Girder Bridge" 		"USATrack5In.sms" "USATrack5Ex.sms"	)
TrackType ( "Under Bridge" 			"USATrack6In.sms" "USATrack6Ex.sms"	)
TrackType ( "Concrete Bridge" 		"USATrack7In.sms" "USATrack7Ex.sms"	)
TrackType ( "Crossing Platform" 	"USATrack8In.sms" "USATrack8Ex.sms"	)
TrackType ( "Wooden Bridge" 		"USATrack9In.sms" "USATrack9Ex.sms"	)
TrackType ( "Curve Squeal" 			"flange_in.sms" "flange_ex.sms"	)


	ORTSCurveSquealSMSNumber ( 10 )


...but nothing happens (I don't hear anything) when a train "rounds the curve."

#4 User is offline   steamer_ctn 

  • Open Rails Developer
  • Group: Status: Elite Member
  • Posts: 1,921
  • Joined: 24-June 11
  • Gender:Male
  • Country:

Posted 18 May 2024 - 10:25 PM

View PostTraindude, on 18 May 2024 - 10:19 PM, said:

NOTE: The reason for the duplicated entries in the ttype.dat file is that the second instance of each entry was originally a "<track type> + flange" entry. These are now made redundant thanks to the addition of the ORTSCurveSquealSMSNumber parameter.

Everything worked fine until about three weeks ago, when the automatic curve squeal stopped working.
This is still a WiP, and as such has not "formally" been released to the broader community as there are changes still being made to it.

As a WiP, it is still subject to change. Hopefully the changes that we have made will make it an even better approach, however they need to be tested and confirmed by the development team for this feature.

The original two methods for Curve Squeal should still work.

#5 User is offline   QJ-6811 

  • Conductor
  • Group: Status: Contributing Member
  • Posts: 404
  • Joined: 27-December 15
  • Gender:Male
  • Simulator:MSTS / Open Rails
  • Country:

Posted 19 May 2024 - 12:20 AM

Hi @Traindude,

I'm not sure if the automatic curve squeal sounds still work in the latest release, but coincidentally I removed them all in my route project last week.
The disadvantage was that the (automatic) Track sounds work "either-or", and not "and-and".
IOW, in a tunnel with partly curves and straights, you either have the squelches sounds or tunnel sounds. (of course also for bridges, platforms, etc.)

I "discovered" that you can also use the "CurveForceControlled" in the track regions, which ultimately gives much better results.
(an example, see attachment).
Attached File  Khyberpass00_ex.zip (1.49K)
Number of downloads: 42

The big advantage now is that you hear the 'correct' background sounds with standard sounds, as well as tunnels, bridges, etc., with additional squeals sounds if applicable.

Not a solution to your problem, but perhaps a good alternative?

(I will send a set in your PM, as an example)

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users