Elvas Tower: Demo Model 1 - Elvas Tower

Jump to content

  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

Demo Model 1 Rate Topic: -----

#1 User is offline   Avo 

  • Hostler
  • Group: Status: Active Member
  • Posts: 63
  • Joined: 08-July 10
  • Gender:Male
  • Country:

Posted 15 April 2015 - 11:21 AM

In the demonstration route demo model 1 at different locations gray areas appear instead of the track. In the video they are missing. What settings do I need to change to fix this?

Attached File(s)



#2 User is offline   JohnnyS 

  • Conductor
  • Group: Status: Active Member
  • Posts: 287
  • Joined: 05-May 11
  • Gender:Male
  • Simulator:OR/MSTS
  • Country:

Posted 15 April 2015 - 11:35 AM

Do the grey tracks disappear if you set the superelevation to '0'?

#3 User is offline   Avo 

  • Hostler
  • Group: Status: Active Member
  • Posts: 63
  • Joined: 08-July 10
  • Gender:Male
  • Country:

Posted 15 April 2015 - 12:01 PM

Yes, with the setting super elevation = 0 the error disappeared. Thank you very much!

#4 User is offline   JohnnyS 

  • Conductor
  • Group: Status: Active Member
  • Posts: 287
  • Joined: 05-May 11
  • Gender:Male
  • Simulator:OR/MSTS
  • Country:

Posted 15 April 2015 - 12:14 PM

View PostAvo, on 15 April 2015 - 12:01 PM, said:

Yes, with the setting super elevation = 0 the error disappeared. Thank you very much!


Would guess there are no acleantrack1 & acleantrack2 .ace files for the procedural track generated with superelevation turned on.

#5 User is offline   captain_bazza 

  • Chairman, Board of Directors
  • PipPipPipPipPipPipPipPipPipPipPip
  • Group: ET Admin
  • Posts: 13,877
  • Joined: 21-February 06
  • Gender:Male
  • Location:Way, way, way, South
  • Simulator:MSTS & OR
  • Country:

Posted 15 April 2015 - 08:52 PM

A note in the OR manual is required, eh?

Cheers Bazza.

#6 User is offline   cjakeman 

  • Vice President
  • PipPipPipPipPipPipPipPip
  • Group: ET Admin
  • Posts: 2,195
  • Joined: 03-May 11
  • Gender:Male
  • Location:Peterborough, UK
  • Simulator:Open Rails
  • Country:

Posted 16 April 2015 - 10:16 AM

Thanks for finding this.

View Postcaptain_bazza, on 15 April 2015 - 08:52 PM, said:

A note in the OR manual is required, eh?

Good idea. This should be general advice, not connected with Demo Model 1.

There are instructions with the Demo Model 1, so I'll update those.

The Stable Installation has super-elevation set to zero, so new users trying out Open Rails won't see this efffect.

#7 User is offline   Csantucci 

  • Member, Board of Directors
  • Group: Status: Elite Member
  • Posts: 5,656
  • Joined: 31-December 11
  • Gender:Male
  • Country:

Posted 17 April 2015 - 11:45 AM

I was quite unhappy for an OR Demo Route that couldn't be used with superelevation, so I have written a track profile for the UKfinescale tracks that are used in such route (and in other routes too).
Here the result:
Attached Image: Demoroute_superelevation.jpg
and here is the track profile: it must be unzipped within a TRACKPROFILES folder that must be created within the SCE folder
Attached File  TrProfile1.zip (934bytes)
Number of downloads: 246
18/4/2015 NOTE: Replaced zip file with correct one.

It is advised to not select a Superelevation > 5, because else the profile begins going under terrain level in the internal part of the curve.
The development was made possible by the excellent manual written by WaltN and by a sample track profile that oo_Kanawa posted in this forum some time ago.

I found a problem with the tracks of this route, that was already signalled some time ago: here two pictures of the same track section, taken with slightly different angles, on a straight track (so this has nothing to do with the track profile I generated).

Attached Image: Trouble1.jpg

Attached Image: Trouble2.jpg

So, simply by changing a bit the angle of view, a part or the other of the sleepers (ties) disappears. This is due to the fact that the distance between the plane of the ballast and the one of the ties is very low (1 mm.). However MSTS has no problem in showing this.
I think it is not nice that the route selected as demo route for OR shows such a problem. As there is at least one OR developer that I believe has clear ideas where to intervene, I kindly ask him to try to find a solution, maybe even with a "dirty" patch (e.g. a patch that applies only to track textures, to avoid problems in other cases).

#8 User is offline   James Ross 

  • Open Rails Developer
  • Group: Status: Elite Member
  • Posts: 5,238
  • Joined: 30-June 10
  • Gender:Not Telling
  • Simulator:Open Rails
  • Country:

Posted 17 April 2015 - 12:26 PM

View PostCsantucci, on 17 April 2015 - 11:45 AM, said:

I think it is not nice that the route selected as demo route for OR shows such a problem. As there is at least one OR developer that I believe has clear ideas where to intervene, I kindly ask him to try to find a solution, maybe even with a "dirty" patch (e.g. a patch that applies only to track textures, to avoid problems in other cases).

If anyone is considering looking at this code, be very careful. The almost certain cause of this diagonal swipe is the adjustment made in the shaders to avoid flickering when two ballast layers are exactly equal in position (e.g. near switches). That's something that shows up a lot due to the way track is laid in the MSTS RE (and reality TBH) so please be careful and test a lot. :)

#9 User is offline   Csantucci 

  • Member, Board of Directors
  • Group: Status: Elite Member
  • Posts: 5,656
  • Joined: 31-December 11
  • Gender:Male
  • Country:

Posted 17 April 2015 - 12:35 PM

Well, James, it's not myself the person that has clear ideas, but you... I hoped it would be you trying to find a solution to this... :) I don't even know where to look in the code, and if it's shaders it's like japanese for me...

#10 User is offline   James Ross 

  • Open Rails Developer
  • Group: Status: Elite Member
  • Posts: 5,238
  • Joined: 30-June 10
  • Gender:Not Telling
  • Simulator:Open Rails
  • Country:

Posted 17 April 2015 - 01:07 PM

View PostCsantucci, on 17 April 2015 - 12:35 PM, said:

Well, James, it's not myself the person that has clear ideas, but you... I hoped it would be you trying to find a solution to this... :) I don't even know where to look in the code, and if it's shaders it's like japanese for me...

Heh, I did wonder if you meant me. :) I've got a few other tasks outstanding for release prep but I'll see what I can do.

  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users