Elvas Tower: OR not recognizing certain entires in Shape files - Elvas Tower

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

OR not recognizing certain entires in Shape files Rate Topic: -----

#1 User is offline   Docmartin 

  • Hostler
  • Group: Status: Active Member
  • Posts: 61
  • Joined: 27-March 18
  • Gender:Male
  • Simulator:Open Rails
  • Country:

Posted 11 January 2022 - 10:12 AM

Whilst I have managed to eliminate all errors flagged in my OR log file, I still have the following three informational statements:

Information: Skipped unknown lighting model index 0 first seen in shape c:\1msts\routes\chiltern\shapes\council3b.s
Information: Skipped unknown lighting model index 1 first seen in shape c:\1msts\routes\chiltern\shapes\warehouse_mcmurrayshippers.s
Information: Skipped unknown shader name Diffuse first seen in shape c:\1msts\routes\chiltern\shapes\16steps.s

It seems that OR does not recognize these items in certain shape files. The phrasing "first seen in shape" suggests that this might be a very common issue with a large number of shape files.

Is it worth taking a look at?

Martin

#2 User is offline   Coolhand101 

  • Foreman Of Engines
  • Group: Status: Contributing Member
  • Posts: 955
  • Joined: 13-June 15
  • Gender:Male
  • Simulator:MSTS
  • Country:

Posted 11 January 2022 - 11:43 AM

View PostDocmartin, on 11 January 2022 - 10:12 AM, said:

Whilst I have managed to eliminate all errors flagged in my OR log file, I still have the following three informational statements:

Information: Skipped unknown lighting model index 0 first seen in shape c:\1msts\routes\chiltern\shapes\council3b.s
Information: Skipped unknown lighting model index 1 first seen in shape c:\1msts\routes\chiltern\shapes\warehouse_mcmurrayshippers.s
Information: Skipped unknown shader name Diffuse first seen in shape c:\1msts\routes\chiltern\shapes\16steps.s

It seems that OR does not recognize these items in certain shape files. The phrasing "first seen in shape" suggests that this might be a very common issue with a large number of shape files.

Is it worth taking a look at?

Martin


Hi

The light model index are invalid texture modes( no texture modes are checked). Go into SFM - Textures - and check a valid option.

Diffuse it not used in OR. Change to TexDiff or BlendATexDiff ,depending if the texture is alpha or not. I test this in Shape Viewer before and after.

These errors will only show if the shape is drawn on the route. You will probably get more of these errors when the whole route is covered.

I cannot remember if "show shapes warnings" in the OR experimental tab will also inform you of these errors.

Thanks

#3 User is offline   Docmartin 

  • Hostler
  • Group: Status: Active Member
  • Posts: 61
  • Joined: 27-March 18
  • Gender:Male
  • Simulator:Open Rails
  • Country:

Posted 12 January 2022 - 08:02 AM

Since the problem lies with the shape file models and there is likely to be a great number of such issues which OR can do nothing about, I just wonder what the point is of OR flagging these items.

Martin

#4 User is offline   cjakeman 

  • Vice President
  • PipPipPipPipPipPipPipPip
  • Group: ET Admin
  • Posts: 2,442
  • Joined: 03-May 11
  • Gender:Male
  • Location:Peterborough, UK
  • Simulator:Open Rails
  • Country:

Posted 14 January 2022 - 10:36 AM

View PostDocmartin, on 12 January 2022 - 08:02 AM, said:

Since the problem lies with the shape file models and there is likely to be a great number of such issues which OR can do nothing about, I just wonder what the point is of OR flagging these items.

OR can't do anything to correct the problem, but isn't it useful for a content creator to know which of his shapes are not working as he intended?

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users