Elvas Tower: Multiplayer problem - Elvas Tower

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Multiplayer problem server crashes Rate Topic: -----

#1 User is offline   alifatico 

  • Apprentice
  • Group: Status: Dispatcher
  • Posts: 48
  • Joined: 25-April 19
  • Gender:Male
  • Simulator:open rails
  • Country:

Posted 26 August 2021 - 09:00 AM

We have been playing Multiplayer for several days with some friends with a private server.

We use the latest Testing version. Throughout the game we have server crashes and traffic lights malfunction, however if we use the stable version nothing abnormal happens.

I send the piece of the .log where the error appears. Any ideas ?.

Error: ScriptManager.Load incorrectly called by Multiplayer Server-Client; must be Loader Process or crashes will occur.
en Orts.Common.ORTraceListener.TraceEventInternal(TraceEventCache eventCache, String source, TraceEventType eventType, Int32 id, String format, Object[] args) en C:\Jenkins\jobs\Open Rails Testing\workspace\Source\Orts.Simulation\Common\ErrorLogger.cs:línea 173
en Orts.Common.ORTraceListener.TraceEvent(TraceEventCache eventCache, String source, TraceEventType eventType, Int32 id, String format, Object[] args) en C:\Jenkins\jobs\Open Rails Testing\workspace\Source\Orts.Simulation\Common\ErrorLogger.cs:línea 123
en System.Diagnostics.TraceInternal.TraceEvent(TraceEventType eventType, Int32 id, String format, Object[] args)
en Orts.Common.Scripting.ScriptManager.Load(String[] pathArray, String name, String nameSpace) en C:\Jenkins\jobs\Open Rails Testing\workspace\Source\Orts.Simulation\Common\Scripting\ScriptManager.cs:línea 65
en Orts.Simulation.RollingStocks.SubSystems.ScriptedTrainControlSystem.Initialize() en C:\Jenkins\jobs\Open Rails Testing\workspace\Source\Orts.Simulation\Simulation\RollingStocks\SubSystems\TrainControlSystem.cs:línea 229

Thank you

Attached File(s)



#2 User is offline   Csantucci 

  • Member, Board of Directors
  • Group: Status: Elite Member
  • Posts: 6,030
  • Joined: 31-December 11
  • Gender:Male
  • Country:

Posted 27 August 2021 - 12:23 AM

I've tried to reproduce this and, yes, I can confirm that I get error messages in the log when a new player whose locomotive has a TCS script enters the game, see log, although I don't get the crash, at least in the short test I did.
Attached File  OpenRailsLog.txt (25.16K)
Number of downloads: 79

#3 User is offline   alifatico 

  • Apprentice
  • Group: Status: Dispatcher
  • Posts: 48
  • Joined: 25-April 19
  • Gender:Male
  • Simulator:open rails
  • Country:

Posted 27 August 2021 - 02:09 AM

 Csantucci, on 27 August 2021 - 12:23 AM, said:

I've tried to reproduce this and, yes, I can confirm that I get error messages in the log when a new player whose locomotive has a TCS script enters the game, see log, although I don't get the crash, at least in the short test I did.
OpenRailsLog.txt


Thank you very much Carlo for your quick reply.
We will try to do a test with the scripts disabled.

Best regards

Pedro.

#4 User is offline   Csantucci 

  • Member, Board of Directors
  • Group: Status: Elite Member
  • Posts: 6,030
  • Joined: 31-December 11
  • Gender:Male
  • Country:

Posted 27 August 2021 - 11:51 AM

To be more precise the error arises for every custom script present on a remote train's loco, e.g. a Circuit Breaker script. Apparently this is a long time existing issue.

#5 User is offline   alifatico 

  • Apprentice
  • Group: Status: Dispatcher
  • Posts: 48
  • Joined: 25-April 19
  • Gender:Male
  • Simulator:open rails
  • Country:

Posted 28 August 2021 - 12:32 AM

Thanks again

Pedro.

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users