Elvas Tower: Timetable $attach command - Elvas Tower

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Timetable $attach command $attach in #dispose field when attaching to player driven train

#1 User is offline   Vasi 

  • Apprentice
  • Group: Status: Switchman
  • Posts: 4
  • Joined: 11-January 20
  • Gender:Male
  • Simulator:Open Rails
  • Country:

Posted 12 January 2020 - 01:32 PM

Hello,

I am trying to use $attach command in my timetable. But I have different behavior with player and AI trains.
The situation is following:
1. Train1 arrives to station2, terminates and forms to Train2
2. Than Helper is activated and moves along path with one reversal point and attaches to the end of Train2. Note: The helper starts at platform and moves on other track of the same platform. So I choose to use $attach command in #dispose field at the end of path.

Beahvior:
1. If the Train1 is driven by AI, it works fine and Helper attaches.
2. If the Train1 is driven by player (than is formed to Train2) Helper does not attach and stops a few meters before player train.
3. If the player starts as Train2, it works fine and Helper attaches.
4. Even if the player start as Train2 and moves a bit before attaching, it works fine and Helper attaches

Attached Image: attach.jpg

This post has been edited by Vasi: 12 January 2020 - 01:36 PM


#2 User is offline   roeter 

  • Vice President
  • Group: Status: Elite Member
  • Posts: 2,070
  • Joined: 25-October 11
  • Gender:Male
  • Country:

Posted 12 January 2020 - 02:47 PM

Cause of the problem : because the player train starts before the additional unit has attached, the path for the player train is set and this prevents the additional unit to attach. Solution is in the making. It will be included in an overall update for timetable mode which also will sort a number of other problems, in particular for usage of turntables. Not all problems are sorted yet, so it will still take some time.

Regards,
Rob Roeterdink

#3 User is offline   Vasi 

  • Apprentice
  • Group: Status: Switchman
  • Posts: 4
  • Joined: 11-January 20
  • Gender:Male
  • Simulator:Open Rails
  • Country:

Posted 13 January 2020 - 09:16 AM

Thank you for you answer, Rob. I am looking forward to it

Regards Vasi

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users