Elvas Tower: OR Object issue... - Elvas Tower

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

OR Object issue...

#1 User is offline   Frank C. 

  • Apprentice
  • Group: Status: First Class
  • Posts: 47
  • Joined: 31-May 10
  • Gender:Male
  • Country:

Posted 12 March 2019 - 07:43 PM

I am currently re-signaling a route, and when I went to test things in OR, I got an error about an object shape not being there or something like that, even though it clearly is.

I can grab the exact line from the OR log tomorrow but for now, does anyone have any insight?

Regards,

-Frank C.

Attached thumbnail(s)

  • Attached Image: OR-RD-closing.jpg


#2 User is offline   ebnertra000 

  • Engineer
  • Group: Status: Active Member
  • Posts: 555
  • Joined: 27-February 17
  • Gender:Male
  • Location:East-Central Minnesota
  • Simulator:OR/TSRE
  • Country:

Posted 12 March 2019 - 08:06 PM

Without seeing an error message, or better yet, a logfile, it'll be pretty difficult to say for sure

#3 User is offline   Frank C. 

  • Apprentice
  • Group: Status: First Class
  • Posts: 47
  • Joined: 31-May 10
  • Gender:Male
  • Country:

Posted 13 March 2019 - 05:51 AM

Now that I'm awake and functioning again...This is the snippet in the error file that I am worried about...Log is attached.

Warning: {TileX:-12944 TileZ:14293 X:-285.703 Y:51.135 Z:-136.033} signal 2569 has invalid shape JJHCTRLSIGREPEATGCOR.S.

Warning: {TileX:-12944 TileZ:14293 X:-231.16 Y:49.635 Z:145.911} signal 2570 has invalid shape JJHCTRLSIGREPEATGCOR.S.

Warning: {TileX:-12944 TileZ:14293 X:-225.933 Y:50.385 Z:146.576} signal 2574 has invalid shape JJHCTRLSIGREPEATGCOR.S.

Warning: {TileX:-12944 TileZ:14293 X:-231.774 Y:50.135 Z:143.008} signal 2576 has invalid shape JJHCTRLSIGREPEATGCOR.S.

Warning: {TileX:-12944 TileZ:14293 X:-9.32801 Y:60.5834 Z:1182.63} signal 2577 has invalid shape JJHSIG2UP02#2.S.

Regards,

-Frank C.

#4 User is offline   Frank C. 

  • Apprentice
  • Group: Status: First Class
  • Posts: 47
  • Joined: 31-May 10
  • Gender:Male
  • Country:

Posted 13 March 2019 - 06:19 AM

The IMAGE in the OP is NOT RELATED to this. It's part of the board recovery!

Regards,

-Frank C.

Attached File(s)



#5 User is offline   lenglel 

  • Apprentice
  • Group: Status: Switchman
  • Posts: 10
  • Joined: 21-April 18
  • Gender:Male
  • Simulator:Open Rails
  • Country:

Posted 13 March 2019 - 04:26 PM

It says the shapes are invalid, not missing. Maybe it's a problem within the shapes, and this error is from the parser, not the loader?

#6 User is offline   eugenR 

  • Conductor
  • Group: Status: Active Member
  • Posts: 381
  • Joined: 15-April 13
  • Gender:Male
  • Simulator:MSTS
  • Country:

Posted 14 March 2019 - 07:35 AM

View PostFrank C., on 13 March 2019 - 05:51 AM, said:

Now that I'm awake and functioning again...This is the snippet in the error file that I am worried about...Log is attached.

Warning: {TileX:-12944 TileZ:14293 X:-285.703 Y:51.135 Z:-136.033} signal 2569 has invalid shape JJHCTRLSIGREPEATGCOR.S.

Warning: {TileX:-12944 TileZ:14293 X:-231.16 Y:49.635 Z:145.911} signal 2570 has invalid shape JJHCTRLSIGREPEATGCOR.S.

Warning: {TileX:-12944 TileZ:14293 X:-225.933 Y:50.385 Z:146.576} signal 2574 has invalid shape JJHCTRLSIGREPEATGCOR.S.

Warning: {TileX:-12944 TileZ:14293 X:-231.774 Y:50.135 Z:143.008} signal 2576 has invalid shape JJHCTRLSIGREPEATGCOR.S.

Warning: {TileX:-12944 TileZ:14293 X:-9.32801 Y:60.5834 Z:1182.63} signal 2577 has invalid shape JJHSIG2UP02#2.S.

Regards,

-Frank C.

I think also, there is a problem in the shape-files.
Are the questionable signals, regardless the warning, displayed and working in the route, or not?
Can you attach here the sigcfg.dat, sigscr.dat and some of the questionable shapes, so we can have a look in the shapefile?

Regards
EugenR

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users