Elvas Tower: Open Rails 1.3E MonoGame available - Elvas Tower

Jump to content

  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

Open Rails 1.3E MonoGame available Rate Topic: -----

#21 User is offline   Hobo 

  • Foreman Of Engines
  • Group: Status: Contributing Member
  • Posts: 873
  • Joined: 19-December 04
  • Gender:Male
  • Location:Paris,Ont- Canada
  • Simulator:OPEN RAILS & MSTS
  • Country:

Posted 22 November 2018 - 08:48 AM

Dave !
I use a Ryzen 1700x @ 3.98 , 32 Gig CL 14 ram @ 3334 , Aorus 1080 ti overclocked , 512 Gig 960 pro M.2 2280 SSD , 1 TB 860 evo SSD , 500 GB 850 evo SSD . 1 TB WD Black HD .
Resolution is 3840 x 2160 and graphics at max quality on card and everything turned on in OR graphics wise .
I usually try to pick a very graphics heavy route and a consist of equal quality . Example used - Rory Rice's blackfoot route v3 and a large passenger consist of PRR T1 with 15 cars .

OR would give me a stationary FPS of 20 in North Battleford yard . MG 4222 or MG 1.3E would be 34 . Out of the yard FPS rise to 70 + for MG .

Primitives - - - Shadow is 13078 and Render is 9738 . That's with all shadows on bsides dynamic .

I'm not saying that's the heaviest load that I can put on the Sim but that's the test I use for all of my video tests . Naturally lower graphics intensive routes look better number wise but I use the same one all the time for a consistent comparison .

Don't know if this helps 'cause every route and consist or location give a different set of figures . I usually get from 40 to 70 percent increase with MG depending on setup .

#22 User is offline   Genma Saotome 

  • Owner and Admin
  • PipPipPipPipPipPipPipPipPipPipPip
  • Group: ET Owner
  • Posts: 13,965
  • Joined: 11-January 04
  • Gender:Male
  • Location:United States
  • Simulator:Open Rails
  • Country:

Posted 06 December 2018 - 08:37 PM

Hobo, that's really a big improvement.

I don't have a MG installation right now... it's not entirely obvious to me what one should do with the downloaded software. Got a tip or two for me?

#23 User is offline   ebnertra000 

  • Foreman Of Engines
  • Group: Status: Contributing Member
  • Posts: 859
  • Joined: 27-February 17
  • Gender:Male
  • Location:East-Central Minnesota
  • Simulator:OR/TSRE
  • Country:

Posted 06 December 2018 - 09:02 PM

You just run MG as a stand-alone installation, separate from the vanilla XNA versions of OR. I have it installed at C:/OR_MG and it runs without trouble. It's just that easy

#24 User is offline   HansJansen 

  • Apprentice
  • Group: Status: Dispatcher
  • Posts: 23
  • Joined: 28-November 17
  • Gender:Male
  • Location:Nuenen, The Netherlands
  • Simulator:Open Rails; Zusi3
  • Country:

Posted 08 December 2018 - 04:04 AM

View PostLindsayts, on 21 November 2018 - 07:50 PM, said:

As I understand it Monogame is system allowing crossplatfrom support for any MIcrosoft XNA4 software and wether OR will run will depend on how good the Linux support for Monogame is (Note: Linux DOES have all the required tools including a C# complier. What is likely requiired is for someone to try and build OR under Linux Monogame.

Note: OR 1.2 is reported to work VERY well under wine on Linux.

Lindsay


Hi Lindsay,

I'm afraid I must disagree with you here...

I tried this some time ago already, and repeated that test this morning with the 1.3 version. Same result: I get the menu program running, but when I hit "Start" nothing happens; the menu just starts again after one or two seconds.

Starting it from a terminal window, I see the following message:
Unhandled Exception:
System.NullReferenceException: Object reference not set to an instance of an object
  at Orts.Processes.Profiler.SetThread () [0x0005e] in <949bfae0278b46838832186016c84dfb>:0 
  at Orts.Viewer3D.Processes.RenderProcess..ctor (Orts.Viewer3D.Processes.Game game) [0x0005e] in <949bfae0278b46838832186016c84dfb>:0 
  at Orts.Viewer3D.Processes.Game..ctor (ORTS.Settings.UserSettings settings) [0x00045] in <949bfae0278b46838832186016c84dfb>:0 
  at Orts.Program.Main (System.String[] args) [0x0004e] in <949bfae0278b46838832186016c84dfb>:0 

Could anybody shed some light on this for me?

Thanks all!

  • 3 Pages +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users