Elvas Tower: Can't find file that's referencing rolling stock - Elvas Tower

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Can't find file that's referencing rolling stock I want to edit the folder name Rate Topic: -----

#1 User is offline   Procopius 

  • Hostler
  • Group: Status: Active Member
  • Posts: 92
  • Joined: 04-September 17
  • Gender:Male
  • Simulator:Microsoft Train Simulator
  • Country:

Posted 10 November 2017 - 12:14 AM

I feel like I'm overlooking something perfectly obvious, but it's really bothering me.

I'm trying to install an activity to the LaSalle, Rockford & Central route. I've tracked down most of the mistakes I made, but I'm still getting an error reading train database. I've got the .wag in my Trainset, but it's in a folder named 'mech_pak1,' and some file is calling for the file in folder 'MECHRFR_SFRC1022.' I've opened up the only consist file I can find associated with the activity, I've looked in the .act, .srv. and .pat files. I've tried the Windows search function (which is how I found the MECHRFR_SFRC1022.wag file in the first place). I've tried a program called Search and Replace, which I have had past success with. Route Riter says there isn't any stock missing from the activity, but MSTS keeps crashing when I try to run this activity (triturn3, if that helps). The Activity Editor crashes when I try to open the activity in it, so that's no help. Any suggestions, or should I just admit defeat and delete the activity?

#2 User is offline   Procopius 

  • Hostler
  • Group: Status: Active Member
  • Posts: 92
  • Joined: 04-September 17
  • Gender:Male
  • Simulator:Microsoft Train Simulator
  • Country:

Posted 10 November 2017 - 05:23 AM

View PostProcopius, on 10 November 2017 - 12:14 AM, said:

I feel like I'm overlooking something perfectly obvious, but it's really bothering me.

I'm trying to install an activity to the LaSalle, Rockford & Central route. I've tracked down most of the mistakes I made, but I'm still getting an error reading train database. I've got the .wag in my Trainset, but it's in a folder named 'mech_pak1,' and some file is calling for the file in folder 'MECHRFR_SFRC1022.' I've opened up the only consist file I can find associated with the activity, I've looked in the .act, .srv. and .pat files. I've tried the Windows search function (which is how I found the MECHRFR_SFRC1022.wag file in the first place). I've tried a program called Search and Replace, which I have had past success with. Route Riter says there isn't any stock missing from the activity, but MSTS keeps crashing when I try to run this activity (triturn3, if that helps). The Activity Editor crashes when I try to open the activity in it, so that's no help. Any suggestions, or should I just admit defeat and delete the activity?


Got the problem solved. It was another one of those files which have separate directories hidden inside a single zip file. I still can't find what activity or service or path or consist or whatever is trying to use the stupid thing. Well, I shouldn't call it stupid, it's actually an excellent model of a mechanical reefer, very well done. It's just that sometimes when I'm installing a whole bunch of files at once I fail to read the readme and then I have problems like this. If I had read the readme I would have seen the individual folders.

#3 User is offline   cr-stagg 

  • Foreman Of Engines
  • Group: Status: Contributing Member
  • Posts: 874
  • Joined: 16-May 05
  • Gender:Male
  • Simulator:OR
  • Country:

Posted 10 November 2017 - 06:49 AM

It is probably being called by a Loose Consist which is listed in the ACT file or it could be being call by an AI consist which is called by a service that is called by the ACT.

Testing the Activity with ConBuilder's activity testing tool will point to the file calling of the "missing" item.

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users