Elvas Tower: Track Viewer not loading one route - Elvas Tower

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Track Viewer not loading one route

#1 User is offline   PA1930 

  • Foreman Of Engines
  • Group: Contributing Member
  • Posts: 781
  • Joined: 16-December 12
  • Gender:Male
  • Simulator:-
  • Country:

Posted 16 April 2017 - 11:06 AM

Hello,

Is it possible to check any reports in regards to the Track Viewer?

I am trying the route "Trať 183" which is freeware and can be downloaded here: http://www.mojevlack...y/1378-plzensko (Registration on website needed).

Track Viewer gives me this error:

Attached Image: TrackViewer.JPG

I have tried the route on ORTS and it works fine. Selecting a correct GLOBAL file does not seem to be the issue.
The Track Viewer opens any other route, though. It can be an issue with this one route, but I have never had this issue before and I'm not sure what is causing it either.

Regards,

Pedro

#2 User is offline   JeroenP 

  • Fireman
  • Group: First Class
  • Posts: 179
  • Joined: 28-December 13
  • Gender:Male
  • Simulator:ORTS
  • Country:

Posted 06 January 2018 - 12:21 PM

Dear Pedro,
I have not been very active and as a result, your problem got no attention.

I have found the issue and fixed it in 4020. The issue was an empty definition in a TrVectorNode, in this case in the Trat_183.rdb:
		TrackNode ( 1740
			TrVectorNode ( )
			TrPins ( 1 1
				TrPin ( 1741 1 )
				TrPin ( 829 1 )
			)
		

I would assume that also others ran into similar issues on other routes. Hopefully it is now a little bit more stable.
Best regards. Jeroen.

#3 User is offline   Goku 

  • Superintendant
  • Group: Elite Member
  • Posts: 1,548
  • Joined: 12-December 13
  • Gender:Male
  • Simulator:my own
  • Country:

Posted 06 January 2018 - 01:16 PM

This is very ugly solution for removing broken tdb lines. I think TSRE will crash here too - definitely on save.

#4 User is offline   PA1930 

  • Foreman Of Engines
  • Group: Contributing Member
  • Posts: 781
  • Joined: 16-December 12
  • Gender:Male
  • Simulator:-
  • Country:

Posted 07 January 2018 - 05:57 AM

View PostJeroenP, on 06 January 2018 - 12:21 PM, said:

Dear Pedro,
I have not been very active and as a result, your problem got no attention.

I have found the issue and fixed it in 4020. The issue was an empty definition in a TrVectorNode, in this case in the Trat_183.rdb:
		TrackNode ( 1740
			TrVectorNode ( )
			TrPins ( 1 1
				TrPin ( 1741 1 )
				TrPin ( 829 1 )
			)
		

I would assume that also others ran into similar issues on other routes. Hopefully it is now a little bit more stable.
Best regards. Jeroen.


Hello,

Better late than never. Thank you very much for this.

Pedro

#5 User is offline   PA1930 

  • Foreman Of Engines
  • Group: Contributing Member
  • Posts: 781
  • Joined: 16-December 12
  • Gender:Male
  • Simulator:-
  • Country:

Posted 07 January 2018 - 05:59 AM

View PostGoku, on 06 January 2018 - 01:16 PM, said:

This is very ugly solution for removing broken tdb lines. I think TSRE will crash here too - definitely on save.


As far as I know this route was built with MSTS Route Editor. It is playable on ORTS, but Track Viewer did crash. I think Jeroen's fix does not change anything on the route's .tdb.

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users